Back to oDesk.com » Love the way you work.

Welcome to the oDesk Community! Connect here with fellow clients, contractors, and oDesk staff. Please review our Usage Policy.

Anyone Else Having Trouble WIth The Site Today?

Something's up with the site today.

It's like they're trying to redesign the site while leaving it online for contractors to work, or something.

Half the time, the site has this orange and white "big block" web 2.0ish Wordpress-style design, the other half of the time it looks the same way it's always looked.

And whenever I try to bid on a job, it asks me to "sign in," even though I'm already signed in. When I click "sign in" it just redirects me to my profile page.

I pretty much can't bid on jobs right now.

Vote Result

----------
Score: 0.0, Votes: 0
Working fine for me... Try

Working fine for me... Try clearing the cache or a different browser may be.. If you still have issues, better contact Support.

oDesk Forum Moderator

Always reach for the skies, for even if you fall, you'll still be on the top of the world...

It has been doing that to me

It has been doing that to me for about two weeks or so.

I just thought my ifeed was dropping data.

me too

It's on my pages too.

yes

I tried to apply for a job yesterday and it did not work, the page just hung there till I hit the cancel button.
It took it as a sign I already had too much work .
This place just gets worse and worse, not sure who they are hiring to do their coding but I am suspecting it is the lowest bidder.

lowest bidder

Margaret P. wrote:
I tried to apply for a job yesterday and it did not work, the page just hung there till I hit the cancel button.
It took it as a sign I already had too much work .
This place just gets worse and worse, not sure who they are hiring to do their coding but I am suspecting it is the lowest bidder.

More than likely hired someone here for $1.69 per hour.