Unity 4.2 or above developer/team required for a FPS game (iOS)

Cancelled - Find more jobs like this here