Need you to test our Android app on your Galaxy S2 Device, with Gingerbread 2.3.5 or 2.3.6

Cancelled - Find more jobs like this here